Project

General

Profile

cmake says: -- Found unsuitable Qt version "5.14.2" from /usr/bin/qmake

Added by kurt krueckeberg 5 months ago

I am using Ubuntu 20.10 with qt5-default installed, which is Qt version 5.4.12. When I run cmake wit the defines below, the output includes the complaint: "-- Found unsuitable Qt version "5.14.2" from /usr/bin/qmake"

cmake -DWT_WRASTERIMAGE_IMPLEMENTATION=GraphicsMagick -DCONNECTOR_HTTP=ON -DHARU_PREFIX=/usr/include -DCMAKE_CXX_STANDARD=17 -DCONNECTOR_FCGI=OFF -DWEBUSER=www-data -DWEBGROUP=www-data ../

Which versions of Qt work with Wt 4.5?


Replies (2)

RE: cmake says: -- Found unsuitable Qt version "5.14.2" from /usr/bin/qmake - Added by Roel Standaert 5 months ago

I don't think there's a particular version restriction in Wt. We just use find_package(Qt5Core) without a version restriction. That's Qt's own CMake config telling you it's unsuitable.

Note: you only need Qt if you want to mix Qt and Wt like the wtwithqt example. Wt does not require Qt.

    (1-2/2)