Project

General

Profile

Bug #6198

Missing Libraries in GIT master Build

Added by Egbert Eich almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
01/08/2018
Due date:
% Done:

0%

Estimated time:

Description

Building libwttest may require the pthreads library

building libfcgi mau require openssl and the pthreads library.

The attached patch makes this build for me.

(Check also:

https://build.opensuse.org/package/show/home:eeich:branches:devel:libraries:c_c/wt)


Files

0001-Add-missing-libraries-to-wttest-and-wtfcgi.patch (1.3 KB) 0001-Add-missing-libraries-to-wttest-and-wtfcgi.patch Patch which makes the build work for me Egbert Eich, 01/08/2018 11:39 PM
0001-Add-missing-libraries-to-wttest-and-wtfcgi.patch (1.42 KB) 0001-Add-missing-libraries-to-wttest-and-wtfcgi.patch Updated fix. Egbert Eich, 01/09/2018 11:45 AM
#1

Updated by Egbert Eich almost 4 years ago

I guess it is better to check for pthread and ssl usage instead of blindly add the libraries. This is at least how it is done in other parts of the clame files. Updated patch below:

#2

Updated by Roel Standaert almost 4 years ago

  • Status changed from New to Resolved

I applied the patch with some minor changes, adding PUBLIC and PRIVATE appropriately, see the latest commit on master.

I tested the patch on build.opensuse.org. I noticed that wt.spec requires more Boost dependencies than we use now. You should be able to leave all of them out, except for boost_thread, boost_program_options, boost_filesystem, and boost_system.

Regards,

Roel

#3

Updated by Egbert Eich almost 4 years ago

Roel, Thanks for the hint!

I've updated the openSUSE package and integrated your fix. I've reduced the boost requires to the once you had listed. I did find, however, that I had to add boost_atomic as well to build successfully everywhere.

#4

Updated by Roel Standaert over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF