Project

General

Profile

Actions

Bug #7187

open

contents of WTabWidget not stretching in height

Added by Marco Kinski almost 5 years ago. Updated over 4 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
08/10/2019
Due date:
% Done:

0%

Estimated time:

Description

After updating from Wt 3.3.11 to 4.1.0 contents of WTabWidget are not stretched in height anymore.

Outside of WTabWidget the content is stretched as before.


Files

main.cpp (2.76 KB) main.cpp Marco Kinski, 08/10/2019 01:07 PM
Actions #1

Updated by Roel Standaert almost 5 years ago

  • Status changed from New to Resolved

We don't actually know how many pixels BorderWidth::Thick is, so we don't properly account for that.

However, if you set the border width to a fixed number of pixels instead, this should work fine with my latest commit (on branches 4.1-release and master).

Actions #2

Updated by Marco Kinski almost 5 years ago

Now i get unwanted H and V scrollbars but i think i can handle these.

Thanks.

Actions #3

Updated by Roel Standaert almost 5 years ago

Those scrollbars, are they maybe caused by the borders? Or is there yet another issue?

Our sizing code compensates for the size of the borders, but only when they have an absolute thickness instead of thin/medium/thick, since we can't know how thick that ends up being in the browser (even though it seems like this is usually 1px@/@3px@/@5px.

I hacked together some code that measures it (briefly creating an invisible div with a border, and then measuring its size), but I didn't bother committing it, since it just felt very hacky and it's just a very unusual thing to have a border that's not an exact amount of pixels thick.

Actions #4

Updated by Marco Kinski almost 5 years ago

I placed the borders to show the heights in this particular example.

In the real world example it's not that simple. I will produce a minimalistic example within the week.

Actions #5

Updated by Marco Kinski almost 5 years ago

After changing the layout behavior from Flex to Javascript by calling:

Wt::WLayout::setDefaultImplementation(Wt::LayoutImplementation::JavaScript); 

the additional scrollbars are gone.

Actions #6

Updated by Roel Standaert almost 5 years ago

I would prefer it to also work if the layout implementation is not JavaScript, though. So it's not related to the borders being set to thick instead of a pixel value?

Actions #7

Updated by Roel Standaert over 4 years ago

  • Status changed from Resolved to Feedback
Actions #8

Updated by Marco Kinski over 4 years ago

I will record remaining problems with flex as separate entries.

Actions

Also available in: Atom PDF