Project

General

Profile

Actions

Bug #7195

closed

contents of WStackedWidget not responding to window size change

Added by Marco Kinski almost 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
08/13/2019
Due date:
% Done:

0%

Estimated time:

Description

After changing from the first Widget to the second all contents of the WStackedWidget are not responding to a window size change anymore.

wt-master: 6b062321668ca1057615300da3d479cd3630e125


Files

main.cpp (3.75 KB) main.cpp Marco Kinski, 08/13/2019 08:28 PM
Actions #1

Updated by Roel Standaert almost 5 years ago

  • Status changed from New to Resolved

Looks like the stacked widget would set the resize sensor's "display" property to "none", causing it to stop working. WStackedWidget needs to ignore the resize sensor, not consider it one of its children. I pushed a fix to 4.1-release and master.

I did notice another strange issue, though: when I was only changing the height of the browser window, it was not being updated, yet when I was changing the width too, it would. I'll have to see what that's about.

Actions #2

Updated by Roel Standaert almost 5 years ago

  • Status changed from Resolved to New

Never mind, it seems that the height change thing was also fixed.

Actions #3

Updated by Roel Standaert almost 5 years ago

  • Status changed from New to Resolved
Actions #4

Updated by Marco Kinski almost 5 years ago

Works for me. Thanks

Actions #5

Updated by Roel Standaert over 4 years ago

  • Status changed from Resolved to Closed

Released in 4.1.1

Actions #6

Updated by Bradley Looy about 4 years ago

This is still an issue in 4.3.1

Actions #7

Updated by Marco Kinski about 4 years ago

I am currently on 4.2.1 and using ``Wt::WLayout::setDefaultImplementation(Wt::LayoutImplementation::JavaScript); // use old layout behaviour``. Works as expected.

Actions #8

Updated by Roel Standaert about 4 years ago

Are you seeing that issue with the cpp file that was provided, or using your own code? Do you have a code sample to reproduce that?

Actions #9

Updated by Bradley Looy about 4 years ago

It was with my code. Sorry, it does appear to be resolved.

Actions

Also available in: Atom PDF