Project

General

Profile

Actions

Bug #7206

closed

setObjectName does not update id/name on wt 4

Added by Marco Kinski almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Target version:
-
Start date:
08/19/2019
Due date:
% Done:

0%

Estimated time:

Description

In wt version 3 setting an object name with: ``setObjectName`` had also the impact of setting the id to "name_autogenerated-unique-id".

I used this fact in test scripts for selenium by searching via xpath: ``[starts-with(@id, 'userid_')]``.

Because the documentation does not state anymore that this is prepended onto the id its likely not a bug.

I suggest adding a notice in the "other changes" section of the changelog.

Actions #1

Updated by Roel Standaert almost 5 years ago

I can add a mention of that in the changelog.

What actually changed is it no longer influences the id (which is good, because you don't want to touch the id), but it now is in an extra attribute (data-object-name). You can still target it with Selenium and we actually updated the selenium locators to reflect that (selenium/wtLocators.js in the Wt source code).

Actions #2

Updated by Roel Standaert almost 5 years ago

  • Status changed from New to Resolved
Actions #3

Updated by Roel Standaert almost 5 years ago

I added it to the release notes (but not on the website yet).

Actions #4

Updated by Roel Standaert almost 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF