Bug #7703


Issue with wt-4.4.0 WStackedWidget/Help needed

Added by Primus Mutasingwa over 3 years ago. Updated over 3 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:



I have downloaded the wt-4.4.0 library from your site and attempted to build a simple web app.

I have a top level widget which is a "WStackedWidget" . The stacked widget is supposed to have several

Container Widgets, each using Layouts (WGridLayout, WVBoxLayout, WHBoxLayout) to organize items inside them.

What I am noticing is that when my application starts, it successfully loads/renders the first item added by the stacked widget.

This first item has a button called "Register" which is supposed to make the Stacked widget load a different Item.

Unfortunately when WStackedWidget loads the 2nd item, it is missing items. Especially those created using "Layouts".

When I run my program on my computer (ubuntu18.04, firefox browser or Chrome Browser) I have observed that if I minimize or resize my Browser window

my missing widgets appear.

It behaves as if resizing or minimizing the browser generates a signal that causes my widgets to display properly.

I did not see this problem when I run the browser on a tablet.

I am attaching a set of files that shows exactly what I am doing. (issueSummary.tar.gz)


---DebugApp.cpp (top level entry)

--- ViewTopLeveL.* top level Container widget that has a stacked widget inside it.

--- ViewLoginRegister.* This widget gets loaded first. It appears to be find

--- ViewSample1.* This widget doesnt show up properly. All things that are added using "Layouts" seem to have problems.

When I change the order and add ViewSample1 before ViewLoginRegister the problem appears on the ViewLoginRegister page.

Please let me know if there is anything wrong with what I am doing. If you think there is a known problem with this version,

let me know of any workaround that you are aware of.

Note: I also noticed that you may have had a related bug in the past but it is not quite the same. (Bug #7550)

Thank you.


issueSummary.tar.gz (26.7 KB) issueSummary.tar.gz Files to help reproduce problem Primus Mutasingwa, 09/04/2020 08:19 PM
Actions #1

Updated by Primus Mutasingwa over 3 years ago

More clarification: When I used the web browser on tablet instead of a computer to access my webApp, It was an Android Tablet.


Also available in: Atom PDF