Project

General

Profile

Actions

Bug #8577

closed

test.http reports two failing tests related to trusted proxies

Added by Bruce Toll over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
Roel Standaert
Target version:
Start date:
05/24/2021
Due date:
% Done:

100%

Estimated time:

Description

With Wt 4.5.0-rc1-52-g42a5ef9f (github master), I've encountered two test failures with test.http. It may be a mistake on my part with configuration or how I'm running the tests. I've attached the test output, as well as a patch for your review that helps the tests pass in my environment.


Files

Actions #1

Updated by Korneel Dumon over 2 years ago

According to the documentation in wt_config.xml, I think it's actually the second test (for Client-IP) that should use the trusted proxy list.

Actions #2

Updated by Bruce Toll over 2 years ago

Hi Korneel,

Thanks for following-up. I think you're right. I probably should have just reported the test failures, as the intended behavior of the tests seemed somewhat ambiguous to me. Please disregard the suggested patch.

--Bruce

Actions #3

Updated by Roel Standaert over 2 years ago

  • Assignee set to Roel Standaert
  • Target version set to 4.6.0
Actions #4

Updated by Roel Standaert over 2 years ago

  • Status changed from New to InProgress
Actions #5

Updated by Roel Standaert over 2 years ago

  • Status changed from InProgress to Review
Actions #6

Updated by Roel Standaert over 2 years ago

  • Status changed from Review to Resolved
Actions #7

Updated by Roel Standaert over 2 years ago

  • % Done changed from 0 to 100
Actions #8

Updated by Roel Standaert over 2 years ago

  • Target version changed from 4.6.0 to 4.5.1
Actions #9

Updated by Roel Standaert over 2 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF