Project

General

Profile

Feature #753

WTextEdit - Feature and code propsition

Added by Thim Anneessens almost 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Pieter Libin
Category:
-
Target version:
Start date:
03/11/2011
Due date:
% Done:

0%

Estimated time:

Description

Hello, I was using WTextEdit with JWt and had a problem because it converted all 'é' charaters in 'é'. The problem was that JWt WText seems to generate some nasty javascript error when you provide a string whit '&eacute'.

So I added a feature to the WTextEdit so that we can specify extra parameters (like entity_encoding:'raw' that will prevent mce to convert charaters).

code is attached.

Kind regards,

Thim.


Files

WTextEdit.java (10.1 KB) WTextEdit.java Thim Anneessens, 03/11/2011 02:13 PM
#1

Updated by Koen Deforche almost 12 years ago

  • Status changed from New to InProgress

Pieter,

That should read as: 'é' charaters in 'é'

Can you reproduce in (in Wt and/or JWt) and review the patch ?

Regards,

koen

#2

Updated by Pieter Libin over 11 years ago

  • Assignee set to Pieter Libin
#3

Updated by Pieter Libin over 11 years ago

  • Status changed from InProgress to Resolved

Hi,

since Wt 3.1.10 the WTextEdit#setConfigurationSetting(String name, Object value) method can set extra config settings,

greetings,

Pieter

#4

Updated by Koen Deforche about 11 years ago

  • Status changed from Resolved to Closed
  • Target version set to 3.2.0

Also available in: Atom PDF