Project

General

Profile

Actions

Bug #8135

closed

WMenu submenu itemselected

Added by Jan Hrubeš over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
02/24/2021
Due date:
% Done:

100%

Estimated time:

Description

Hi,
this is regression of an 10 years old issue. When using a two-level menu, then the selection is not properly propagated to the parent menu.
Thus ".itemselected .itemselected" css selector do not work.
I have found it in issues #694, #1037 and question https://redmine.webtoolkit.eu/boards/2/topics/13923 .
The regression is in wt4 branch, I have tested it on wt 4.4.0.

Example attached.


Files

helloMenu.cpp (2.21 KB) helloMenu.cpp Jan Hrubeš, 02/24/2021 09:48 AM
helloMenu.cpp (3.38 KB) helloMenu.cpp added workaround Jan Hrubeš, 03/10/2021 07:40 PM
Actions #1

Updated by Korneel Dumon about 3 years ago

  • Status changed from New to InProgress
  • Assignee set to Korneel Dumon

Hi,
can you point me to a revision where you still get the old behavior?
I worry about simply selecting the parent item, since that would trigger another itemSelected() signal. Seems to me that might break some code.

Actions #2

Updated by Jan Hrubeš about 3 years ago

Hi,
I am migrating from wt-3.2.3 to wt-4.4.0.

I have written a little workaround (see attachment) with a call "select()" on parent menu item (yes, itemSelected() is triggered).
Also when top menu item is selected, then an item in submenu is selected too.
Wt handle when selection do not change (in WMenu::select()) so no infinite calling one from another occurs.
Sequence of actions can be observed with some trace logging (not included).

Actions #3

Updated by Roel Standaert about 3 years ago

  • Status changed from InProgress to Implemented @Emweb
  • Target version set to 4.6.0
Actions #4

Updated by Roel Standaert almost 3 years ago

  • Status changed from Implemented @Emweb to Resolved
Actions #5

Updated by Roel Standaert almost 3 years ago

  • % Done changed from 0 to 100
Actions #6

Updated by Roel Standaert over 2 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF