Project

General

Profile

Actions

Bug #12145

open

WVBoxLayout: vertical placement is ignored in 4.10.2

Added by S ET 7 months ago. Updated 3 months ago.

Status:
Implemented @Emweb
Priority:
Normal
Target version:
Start date:
11/11/2023
Due date:
% Done:

0%

Estimated time:

Description

Hi,

Since 4.10.2, widgets are not placed vertically in a WVBoxLayout, but horizontally instead. Same in c1abebc. It's OK in 4.10.0 and 4.10.1.

Thanks for considering.

Regards.


Files

wt-vbox.zip (2.29 KB) wt-vbox.zip S ET, 11/14/2023 10:07 PM
Actions #1

Updated by Matthias Van Ceulebroeck 7 months ago

  • Status changed from New to Feedback
  • Assignee set to S ET

Hello,

if I look at /layout/layout-managers of the widget gallery (locally, since the one publicly hosted at https://www.webtoolkit.eu/ is lagging behind a version currently) I do not see this behavior. The text there is still positioned as expected, namely vertically stacked.
Perhaps there is another layout manager that doesn't play nice? Could you provide a minimal example that exhibits the wrong visual layout?

Actions #2

Updated by S ET 7 months ago

Perhaps there is another layout manager that doesn't play nice? Could you provide a minimal example that exhibits the wrong visual layout?

Hi,

The attached file below contains sample project files demonstrating the issue.

It happens in a WPopupWidget, having a WVBoxLayout containing a WSelectionBox, a WCheckBox and 4 WPushButton widgets in a WGridLayout. When the popup is shown, the widget layout is bad in 4.10.2.

If the same widget disposition is applied in root(), the layout is good.

Thank you for considering.

Actions #3

Updated by Matthias Van Ceulebroeck 6 months ago

  • Status changed from Feedback to InProgress
  • Assignee changed from S ET to Matthias Van Ceulebroeck
  • Target version set to 4.10.3

Thank you for the example.

I was able to quickly determine the root cause! The fix will be included in the next release.

Actions #4

Updated by Matthias Van Ceulebroeck 6 months ago

  • Status changed from InProgress to Review
  • Assignee deleted (Matthias Van Ceulebroeck)
Actions #5

Updated by Matthias Van Ceulebroeck 5 months ago

  • Assignee set to Korneel Dumon
Actions #6

Updated by Matthias Van Ceulebroeck 5 months ago

  • Target version changed from 4.10.3 to 4.11.0
Actions #7

Updated by Korneel Dumon 5 months ago

  • Status changed from Review to Resolved
  • Assignee changed from Korneel Dumon to Matthias Van Ceulebroeck
Actions #8

Updated by Korneel Dumon 5 months ago

  • Status changed from Resolved to InProgress
Actions #9

Updated by Matthias Van Ceulebroeck 4 months ago

  • Status changed from InProgress to Review
  • Assignee deleted (Matthias Van Ceulebroeck)
Actions #10

Updated by Matthias Van Ceulebroeck 4 months ago

  • Assignee set to Korneel Dumon
Actions #11

Updated by Matthias Van Ceulebroeck 4 months ago

  • Status changed from Review to Implemented @Emweb
  • Assignee changed from Korneel Dumon to Matthias Van Ceulebroeck
  • Target version changed from 4.11.0 to 4.10.4
Actions #12

Updated by Apivan Tuntakurn 3 months ago

diff --git a/src/web/DomElement.C b/src/web/DomElement.C
index 13bccc09..1d7ed351 100644
--- a/src/web/DomElement.C
+++ b/src/web/DomElement.C
@@ -135,7 +135,7 @@ std::string cssCamelNames_[] =
     "border-collapse",
     "pageBreakBefore", "pageBreakAfter",
     "zoom", "visibility", "display",
-    "boxSizing", "flex", "flexFlow", "alignSelf", "justifyContent"
+    "boxSizing", "flex", "flexDirection" , "flexFlow", "alignSelf", "justifyContent"
   };

 const std::string unsafeChars_ = " $&+,:;=?@'\"<>#%{}|\\^~[]`/";

Actions #13

Updated by S ET 3 months ago

Now it's working as expected in 4.10.4. Thank you.

Actions

Also available in: Atom PDF