Project

General

Profile

Actions

Bug #906

closed

Unable to install Wt on Windows

Added by Alec Taylor about 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
07/17/2011
Due date:
% Done:

0%

Estimated time:

Description

I'm unable to install Wt on Windows.

Specs:

Windows 7 SP1 64-bit

Boost 1.47.0 (extracted .zip to C:\boost_1_47_0 then ran b2 install ---prefix=C:\boost)

CMake 2.8.4 (set BOOST_DIR, BOOST_PREFIX, Boost_INCLUDE_DIR:PATH, Boost_LIB_DIAGNOSTIC_DEFINITIONS, Boost_PROGRAM_OPTIONS_LIBRARY:FILEPATH and Boost_ROOT to C:\boost. Visual Studio 10 x64 with use native settings)

Wt 3.1.9 (+ mkdir c:\libraries mkdir c:\libraries\lib mkdir c:\libraries\include)

Output of CMake (following this guide: http://redmine.webtoolkit.eu/projects/wt/wiki/Installing_Wt_on_MS_Windows [The quick method]): http://pastebin.com/rGdWzyb5

Please tell me where I went wrong so I can use Wt on Windows.

Thanks,

Alec Taylor

Actions #1

Updated by Koen Deforche about 13 years ago

  • Status changed from New to InProgress
  • Assignee set to Wim Dumon
Actions #2

Updated by Wim Dumon about 13 years ago

This is your reason why cmake fails:

ERROR: Boost_ROOT is not the correct spelling. The proper spelling is

BOOST_ROOT.

I just did a grep over the entire source code, but could not find a file that mentions the variable Boost_ROOT. Wt seems to use BOOST_ROOT. I use cmake 2.8.4 on windows, which works fine for me.

Note if you compile boost yourself: boost libraries have many different naming options, and cmake fails to recognize some of them. The installation instructions for boost frequently change inbetween versions, so it's hard for us to supply simple instructions that will work for boost. Usually it works when you add ---layout=versioned to your bjam options. But ultimately, to find out whether cmake found your boost libaries, it's best to look in your CMakeCache.txt file.

Actions #3

Updated by Alec Taylor about 13 years ago

Thanks, just ran it again, it requested 3 variables be defined (BOOST_COMPILER, BOOST_DIR and BOOST_VERSION) which I set as gcc44, C:\boost and 1_47.

CMake log output: http://pastebin.com/9p28Mref

I couldn't find the CMakeCache.txt file for this version of Wt, but I noticed in my old Wt folder (which I also couldn't get working, when I was trying with Wt 3.1.9 and BOOST 1.46.1) a CMakeCache.txt file you may find useful: http://pastebin.com/gdwyLap1

Please tell me what I should do next in order to get Wt working on Windows.

Thanks,

Alec Taylor

Actions #4

Updated by Alec Taylor about 13 years ago

Hold on, just noticed I had the old (Wt 3.1.9) Build directory configured in CMake 2.8.4... just changed that to the new directory, and I think it worked.

Currently testing the SLN

:]

Thanks for the help!

Actions #5

Updated by Alec Taylor about 13 years ago

Here's the Build log: http://pastebin.com/wDmQEYJg

Build: 5 succeeded, 38 failed, 1 up-to-date, 2 skipped

Hopefully that's a good sign!

Actions #6

Updated by Alec Taylor about 13 years ago

Hmm, I tried to build an example (The Hello example), but got this: http://pastebin.com/Ci0jUGyR

Build: 0 succeeded, 3 failed, 1 up-to-date, 0 skipped

(FYI: I followed this guide to get this far --- http://redmine.emweb.be/projects/wt/wiki/Installing_Wt_on_MS_Windows)

Maybe it would be easier using Code::Blocks from CMake (Code::Blocks is my preferred IDE, but I do have a full license for VS2010)?

Anyways, could please tell me how I can get one of these example projects compiled.

Thanks,

Alec Taylor

Actions #7

Updated by Benjamin Beier almost 13 years ago

Haha, I just tried the same thing and found this ticket with google.

Are there any solutions by now?

Thanks,

Ben

Actions #8

Updated by Wim Dumon almost 13 years ago

benjamin,

is that also with boost 1.47 and wt 3.1.9?

w.

Actions #9

Updated by Benjamin Beier almost 13 years ago

I'm getting always the same errors...

Tried:

  • BoostPro libs 1.47 + WT 3.1.9 / WT 3.1.10 -> CMake 2.8 (Visual Studio 10)
  • Self-compiled boost 1.47 (64bit) + WT 3.1.9 / WT 3.1.10 -> CMake 2.8 (Visual Studio 10 Win64)
Actions #10

Updated by Wim Dumon almost 13 years ago

The problems are caused by the use of the latest boost versions. I made some modifications to Wt (workarounds and improvements), which will be in public git soon. This should resolve the compile problems on windows; could you keep an eye on the git repository in the next couple of days and report whether it works for you?

Actions #11

Updated by Benjamin Beier almost 13 years ago

Rebuild All: 47 succeeded, 0 failed, 0 skipped

Thanks a lot ;)

Actions #12

Updated by Koen Deforche almost 13 years ago

  • Status changed from InProgress to Resolved
  • Target version set to 3.1.11
Actions #13

Updated by Alec Taylor almost 13 years ago

Unfortunately it's not working for me (yet).

CMake 2.8.5, Visual Studio 2010 x64, Boost 1.47 (install from source, using b2) and latest git snapshot of Wt (3.1.11?) on Windows 7 x64: http://pastebin.com/SBNp077s (Build Log)

Build: 8 succeeded, 39 failed, 0 up-to-date, 2 skipped

Please help me get Wt compiled and working on Windows.

Thank you,

Alec Taylor

Actions #14

Updated by Wim Dumon almost 13 years ago

Your compilation log is full of these:

libboost_program_options-vc100-mt-1_47.lib(value_semantic.obj) : fatal error LNK1112: module machine type 'X86' conflicts with target machine type 'x64'

You installed a 32-bit boost, but are compiling a 64-bit Wt. Change one of the two so that they correspond...

Wim.

Actions #15

Updated by Alec Taylor almost 13 years ago

Thanks, no failed this time :]

Now just need to find my wt.dll and wthttp.dll... any ideas?

Actions #16

Updated by Wim Dumon almost 13 years ago

Build the 'INSTALL' target and they will be copied to the CMAKE_PREFIX_DIR (or however the variable is called). By default, it's c:/Program Files/WT. And by default, wt builds static .lib files, not .dll files. This can also be configured in cmake (I believe the option is called SHARED_LIBS)

Actions #17

Updated by Alec Taylor almost 13 years ago

Thanks. All compile successfully now.

Unfortunately I'm now stuck on another error.

Here is my configuration: http://i54.tinypic.com/34qmjoh.png

Here is the error: http://i53.tinypic.com/24pmn38.png

Please tell me how to fix this so I can finally begin using Wt.

Thanks for all suggestions,

Alec Taylor

Actions #18

Updated by Wim Dumon almost 13 years ago

Right-click on 'hello.wt' and select 'Set as startup project'

Wim.

Actions #19

Updated by Alec Taylor almost 13 years ago

Thanks, almost working now.

Command window opens, seemed to be working, but couldn't access. Changed IP address to the windows localhost (127.0.0.1), it is now working... sort of

Option no-compression is implied because wthttp was built without zlib support.
Option no-compression is implied because wthttp was built without zlib support.
[2011-Sep-07 23:24:44.778594] 536 - [notice] "Started server: http://127.0.0.1:8080"
127.0.0.1 - - [2011-Sep-07 23:24:57.491321] "GET / HTTP/1.1" 404 85
127.0.0.1 - - [2011-Sep-07 23:24:57.790339] "GET /favicon.ico HTTP/1.1" 404 85
127.0.0.1 - - [2011-Sep-07 23:24:57.823340] "GET /favicon.ico HTTP/1.1" 404 85
127.0.0.1 - - [2011-Sep-07 23:25:00.389487] "GET /favicon.ico HTTP/1.1" 404 85

BTW: This is just the unedited hello.wt project.

Any ideas?

Thanks for all suggestions,

Alec Taylor

Actions #20

Updated by Wim Dumon almost 13 years ago

Since your deployment path is set to /hello, you'll have to surf to http://localhost:8080/hello instead of http://localhost:8080/

Listening on address 0.0.0.0 on windows will usually require you to change your windows firewall to allow the wt application to receive incoming TCP connections.

Wim.

Actions #21

Updated by Alec Taylor almost 13 years ago

Thanks, beginners mistake.

(I actually tested that before I wrote my previous post, but it didn't load, seems like when I copied & pasted the console output it had paused the server)

All working now, close this bug! :D

Actions #22

Updated by Koen Deforche almost 13 years ago

  • Status changed from Resolved to Closed

Resolved in Wt 3.1.11

Actions

Also available in: Atom PDF