Project

General

Profile

Actions

Bug #11804

closed

WEmailValidator fails when domain name contains a hyphen

Added by Stefan Bn 10 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
07/06/2023
Due date:
% Done:

100%

Estimated time:

Description

The new WEmailValidator introduced in Wt 4.10.0 does not allow hypens in the domain name.
Thus it rejects valid email adresses if they contain a hyphen in the domain name.

user@exampledomain.org > Is OK
user@example-domain.org > Is rejected (see screenshot attached)

I see this behavior in Firefox and MS Edge and it can be reproduced using the Email Edit section in Wt Widget Gallery.

https://webtoolkit.eu/widgets/forms/line_text-editor


Files

wemailvalidator_failure.png (7.41 KB) wemailvalidator_failure.png Stefan Bn, 07/06/2023 10:56 AM
Actions #1

Updated by Matthias Van Ceulebroeck 9 months ago

  • Target version set to 4.10.1

This indeed is a bug. The regex that performs the validation is copied from the HTML standard, but there seems to be an issue with it.

Actions #2

Updated by Matthias Van Ceulebroeck 9 months ago

  • Status changed from New to InProgress
  • Assignee set to Matthias Van Ceulebroeck
Actions #3

Updated by Matthias Van Ceulebroeck 9 months ago

  • Status changed from InProgress to Review
  • Assignee deleted (Matthias Van Ceulebroeck)
Actions #4

Updated by Matthias Van Ceulebroeck 9 months ago

  • Assignee set to Korneel Dumon
Actions #5

Updated by Korneel Dumon 9 months ago

  • Status changed from Review to Implemented @Emweb
  • Assignee changed from Korneel Dumon to Matthias Van Ceulebroeck
Actions #6

Updated by Matthias Van Ceulebroeck 9 months ago

  • % Done changed from 0 to 100
Actions #7

Updated by Matthias Van Ceulebroeck 7 months ago

  • Status changed from Implemented @Emweb to Closed
Actions

Also available in: Atom PDF