Project

General

Profile

Actions

Bug #9076

closed

Opening popup (calendar) of Wt::WDateEdit fails in Widgetset mode on first render.

Added by Dries Mys over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
09/17/2021
Due date:
% Done:

100%

Estimated time:

Description

Consider the following example:

A simple WidgetSet application with a single Wt::WDateEdit (and a Wt::WPushButton)

std::unique_ptr<Wt::WContainerWidget> pWidget = std::make_unique<Wt::WContainerWidget>();
auto pRoot = pWidget.get();
bindWidget(std::move(pWidget), "WidgetHolder");

pRoot->addNew<Wt::WDateEdit>();
pRoot->addNew<Wt::WPushButton>("Fix WDateEdit")->clicked().connect([](){});

When the user clicks on the calendar icon to open the calendar popup, a JS error occurs inside WDateEdit.js

 p is undefined

indicating that the popup does not exist yet (Wt::WPopupWidget::render is not yet called).

After a new round trip (js update) to the server, for example by clicking on the Wt::WPushButton, the issue is resolved.

Note that the problem does not occur for an Application entry point.


Related issues 3 (3 open0 closed)

Related to Bug #10923: WidgetSet mode doesn't bootstrap properlyNew09/08/2022

Actions
Related to Bug #12022: Session crash due wrong renderingImplemented @EmwebMatthias Van Ceulebroeck10/11/2023

Actions
Related to Bug #11669: Delayed invisible changes end up in prelearned stateless slotImplemented @EmwebMatthias Van Ceulebroeck05/25/2023

Actions
Actions #1

Updated by Korneel Dumon over 2 years ago

  • Status changed from New to InProgress
  • Assignee set to Korneel Dumon
  • Target version set to 4.7.0
Actions #2

Updated by Korneel Dumon about 2 years ago

  • Status changed from InProgress to Review
  • Assignee deleted (Korneel Dumon)
Actions #3

Updated by Roel Standaert almost 2 years ago

  • Target version changed from 4.7.0 to 4.8.0

I'm going to delay this, because I still need more time to properly review this.

Actions #4

Updated by Roel Standaert over 1 year ago

  • Target version changed from 4.8.0 to 4.9.0
Actions #5

Updated by Roel Standaert over 1 year ago

  • Related to Bug #10923: WidgetSet mode doesn't bootstrap properly added
Actions #6

Updated by Roel Standaert over 1 year ago

  • Status changed from Review to Implemented @Emweb
  • Assignee set to Korneel Dumon
  • % Done changed from 0 to 100
Actions #7

Updated by Roel Standaert over 1 year ago

  • Status changed from Implemented @Emweb to Resolved
Actions #8

Updated by Roel Standaert about 1 year ago

  • Status changed from Resolved to Closed
Actions #9

Updated by Matthias Van Ceulebroeck 5 months ago

  • Related to Bug #12022: Session crash due wrong rendering added
Actions #10

Updated by Matthias Van Ceulebroeck 5 months ago

  • Related to Bug #11669: Delayed invisible changes end up in prelearned stateless slot added
Actions

Also available in: Atom PDF